Adobe continues to work at a feverish pace to address critical security vulnerabilities in its product line. Their most recent patch addresses a total of ten security flaws across the following four products:

  • Photoshop
  • Adobe Digital Editions
  • Adobe Bridge
  • RoboHelp

Of the ten flaws addressed by the latest patch, seven are rated as being Critical in their severity as they allow either arbitrary file writes or arbitrary code execution when exploited.

Adobe Bridge got the most attention, with the patch addressing four critical flaws and two additional vulnerabilities rated as ‘Important.’ Next up, the patch deals with a pair of security flaws in Photoshop, and one critical issue each in RoboHelp and Adobe Digital Editions.

If you use any of the products listed above, you should update to the latest version as soon as possible to minimize your risk. In most cases, this is as simple as firing up the software in question and navigating to Help, and then to “Check for updates,” although if this happens not to work for you, it’s easy enough to simply head to Adobe’s Download Center and grab the files you need from there.

Adobe has had an unfortunate history with many of their products, which have seen more than their share of security flaws. However, to the company’s credit, they’ve abandoned the worst offenders, like their beleaguered Flash player, and have been steadily working to shore up the rest.

Kudos to Adobe for keeping up the good work and for addressing so many security issues with this latest update. As mentioned, if you use any of the products above, be sure to update as soon as possible. Hackers around the world seem to have a soft spot for Adobe products and the longer you wait to patch, the higher your risks.

Used with permission from Article Aggregator

We're Here To Help!

Office

PO Box 41063
Brecksville, OH 44141

Hours

24 / 7 / 365

Call Us

(440) 838-8300

Recommended
Back in February, Google began experimenting with a new feature…